error: The best solution to the Microsoft Visual C++ 14.0 is required problem

created at 10-17-2021 views: 1

For programmers, they often pip install the packages they need. Most of the packages can basically be installed, but they will always encounter the problem that the package cannot be installed. The first step of pre-study learning motivation is killed by the installation package. One of the most troublesome is this problem: 

error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual……

Python3 is compiled with VC++14, python27 is compiled with VC++9, and the package to install python3 needs to be compiled and supported by VC++14 or above.
The above is my history of stepping on the pit, but it has not solved my problem. If you encounter an error: error: Microsoft Visual C++ 14.0 is required, please try the following solution first.

final solution:

None of the above can be solved, so I had to install Microsoft visual c++ 14.0 obediently, and I found a lot of packages, and finally found a Microsoft Visual C++ Build Tools 2015

The file name is: visualcppbuildtools full, just download it and install it. Link: http://go.microsoft.com/fwlink/?LinkId=691126

Double-click visualcppbuildtools_full.exe, select the default, click install, and wait for about 10 minutes to complete the installation.

Please log in to leave a comment.