Flutter upgrade reports SSL_ERROR_SYSCALL error when upgrading SDK

created at 09-11-2021 views: 14

background

When upgrading Flutter, execute the following command



Flutter upgrade

Unfortunately, due to some reasons, it cannot be accessed. Report the following error

Standard error: fatal: unable to access
'https://github.com/flutter/flutter.git/': LibreSSL SSL_connect:
SSL_ERROR_SYSCALL in connection to github.com:443

solution

You can set the walking proxy, the command is as follows:

git config --global http.proxy http://127.0.0.1:1080
git config --global https.proxy http://127.0.0.1:1080

Need to pay attention to the port modification according to your own configuration. Set not to set https according to your own needs.
If you want to cancel the proxy settings, you can use the following command:

git config --global --unset http.proxy 
git config --global --unset https.proxy

After setting, test OK

The git config --global command will add the following configuration to the ~/.gitconfig file

[http]
    proxy = http://127.0.0.1:1080
[https]
    proxy = https://127.0.0.1:1080

Note:
There is another way to use this command, not tested yet, just provide it here

git config --global --add remote.origin.proxy
created at:09-11-2021
edited at: 09-11-2021: