ERROR : Error appeared during Puppet run: 192.168.171.200_mariadb.pp

created at 08-24-2021 views: 40

error message

192.168.171.200_mariadb.pp:                       [ ERROR ]           
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.171.200_mariadb.pp
Error: Execution of '/usr/bin/rpm -e mariadb-server-5.5.41-2.el7_0.x86_64' returned 1: error: Failed dependencies:
You will find full trace in log /var/tmp/packstack/20210819-102416-FTk8cq/manifests/192.168.171.200_mariadb.pp.log
Please check log file /var/tmp/packstack/20210819-102416-FTk8cq/openstack-setup.log for more information

reason

dependency problem of akonadi-mysql.

solution

Remove MariaDB and reinstall

[root@controller ~]# yum remove -y mariadb
[root@controller ~]# yum install -y mariadb mariadb-server
created at:08-24-2021
edited at: 08-24-2021: