ERROR ITMS-90635

created at 08-06-2021 views: 2

iOS package upload has an error of ERROR ITMS-90635, as required, modify the enable bitcode.

project->targets->enable bitcode->no
pods->project->enable bitcode->no

Unfortunately, it has no effect.
If you find it later, you can add the following code to the Podfile for processing:

platform :ios, '9.0'
use_frameworks!

target'XXXX' do
     pod'XXXXXX'
end

# Implement post_install Hooks
post_install do |installer|
   # 1. Traverse all targets in the project
   installer.pods_project.targets.each do |target|
     # 2. Traverse build_configurations
     target.build_configurations.each do |config|
       # 3. Modify ENABLE_BITCODE in build_settings
       config.build_settings['ENABLE_BITCODE'] ='NO'
     end
   end
end

Repackage and upload, over!

created at:08-06-2021
edited at: 08-06-2021: