ERROR: Could not find a version that satisfies the requirement PIL (from versions: none)

created at 08-04-2021 views: 248

If you are the version of Python3, when installing PIL, the following error will appear.

ERROR: Could not find a version that satisfies the requirement PIL (from versions: none)
ERROR: No matching distribution found for PIL
WARNING: You are using pip version 21.1.1; however, version 21.2.1 is available.
You should consider upgrading via the 'D:\python\Scripts\python.exe -m pip install --upgrade pip' command.

This means that PIL does not currently support python3, and currently only supports python2. So can't it be used in python3?

Of course not. After querying the data, it is found that if Pillow is used instead of PIL on python3, all functions of PIL can be called normally as long as Pillow is installed.

If you want to use Pillow after installing Pillow, you cannot use import Pillow, and the execution will report the following error.

ModuleNotFoundError: No module named 'Pillow'

Instead, use the import PIL call directly.

created at:08-04-2021
edited at: 08-04-2021: