Docker-Compose RabbitMQ error: RABBITMQ_DEFAULT_PASS is set but deprecated

created at 08-02-2021 views: 4

description

Docker-Compose RabbitMQ error:

error: RABBITMQ_DEFAULT_PASS is set but deprecated
error: RABBITMQ_DEFAULT_USER is set but deprecated
error: deprecated environment variables detected
Please use a configuration file instead; visit https://www.rabbitmq.com/configure.html to learn more

Configuration information:

Configuration

reason

After Rabbitmq 3.9, variables such as RABBITMQ_DEFAULT_PASS/RABBITMQ_DEFAULT_USER have been removed.

solution

environment:
      - TZ=Asia/Shanghai  
Please log in to leave a comment.