error: Microsoft Visual C++ 14.0 or greater is required. Get it with Microsoft C++ Build Tools

created at 07-31-2021 views: 9

Problem

C++ requirement exception occurs in python setup.py install

solution

Step 1: Ensure that the computer has VS2015 or higher, mine is VS2017
Step 2: Add system environment variables (key)

As follows:

C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\bin\Hostx64\x64
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\Build
created at:07-31-2021
edited at: 07-31-2021: