centos8+mongodb error mongod: error while loading shared libraries: libcrypto.so.1.1: cannot open sha

created at 02-23-2022 views: 24

problem

The error message is as follows:

mongod: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

reason and solution

This is a new version of the system that does not have or lacks this library. It is best to install the latest version of the relevant software package, as follows:

dnf install -y compat-openssl11

Usually pay attention to go to the Linux related package management website to solve the problem of lack of dependencies

created at:02-23-2022
edited at: 02-23-2022: