Vbox installation ubuntu16.04 shared folder suddenly fails (prompt: error: unrecognized command line option ‘-fstack-protector-strong’)

created at 12-30-2021 views: 17

cause investigation

#gcc -v

Found to be the version of 4.7.7

but

screenshot

The installation of the above enhanced software requires the gcc5.4 version that comes with 16.04

solution

1 sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-5 100
2 sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 50
3 sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-5 100
4 sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.7 50

Then reinstall

#./autorun.sh

solved.

created at:12-30-2021
edited at: 12-30-2021: